This project has moved and is read-only. For the latest updates, please go here.

cannot read or modify m4v file

Oct 9, 2013 at 6:18 AM
I want to add chapters to a video transcoded by handbrake 0.99.
Never used drax before. Platform is Windows 7 x64.

drax can read the contents & the current chapters, & I can edit them;
but when I select "save", I get this popup:
Cannot read or modify M4V file
(doesn't matter if it's m4v or mp4, same result)

What can be done to fix this?
Coordinator
Oct 9, 2013 at 3:49 PM
Oops, that is strange. What happens if you just open the file, then remove a chapter, and then save the file?
Oct 9, 2013 at 8:29 PM
It was acting the same - any change + save resulted in that message.

However: I copied the original transcoded file to a new one, & tried editing that;
no problem. I then transcoded another old dvd & tried working on that result;
no problem with that file, either. The original one is still unhappy, so
I just deleted it & moved on. There was nothing about that file that
indicated any security or read/write issues from Windows' perspective.
Coordinator
Oct 10, 2013 at 7:41 AM
Again, that is really strange. Is the file attribute "read-only" set for the original file?
Oct 10, 2013 at 7:45 AM
mo


Oct 10, 2013 at 7:46 AM
I mean, "no" - file was r/w


Sep 27, 2016 at 7:21 PM
The same thing happened to me. I can't edit a lot of mp4 files; the same message appears. Please solve this issue in next update.

P.S. The files were r/w mode.